Frame Relay Point to Point Configuration

Objective: This lab will provide the understanding of how to configure frame relay point-to-point interfaces on Cisco routers. Creating point-to-point frame relay links is a fundamental skill that network engineers need to be able to perform.

Purpose: Frame relay is a WAN technology used to send frames over virtual circuits that are locally identified as Data Link Connection Identifier (DLCI) numbers. In this lab we will use a preconfigured frame relay switch which can be found here. The purpose will be to configure three remote office routers to enable frame relay communication from the remote offices to each other office without the need of static routing. (This lab can be continued from the frame relay static config lab, you will just need to remove the ip addresses from the serial interfaces before beginning.)

Topology:p2p

Task 1: Use the proper cables to connect the ports as shown in the topology.

Task 2:  Configure host names on routers R1, R2, and R3 as shown in the topology.

Task 3:  Enable frame relay switching, configure the sub interfaces for point-to-point frame relay, and configure the sub interface IP addresses on each router in the topology.

Task 4: Verify configuration is working on all routers by pinging from R1 to R2 and R3.

Task 5:  Enable full mesh between all offices with a default ip route on R2 and R3.

Task 6: Verify full configuration is working on all routers and ping from every device to every other device.

 

ANSWER:

Task 1:
We need to use a crossover cables to connect two like devices.

Task 2:
R1
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#

R2
Router>en
Router#conf t
Router(config)#hostname R2
R2(config)#

R3
Router>en
Router#conf t
Router(config)#hostname R3
R3(config)#

Task 3:
R1
R1(config)#frame-relay switching
R1(config)#int s0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay intf-type dte
R1(config-if)#int s0/0.102 point-to-point
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#frame-relay interface-dlci 102
R1(config-if)#int s0/0.103 point-to-point
R1(config-if)#ip address 10.1.2.1 255.255.255.0
R1(config-if)#frame-relay interface-dlci 103
R1(config-if)#no shut

R2
R2(config)#frame-relay switching
R2(config)#int s0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay intf-type dte
R2(config-if)#int s0/0.201 point-to-point
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#frame-relay interface-dlci 201
R2(config-if)#no shut

R3
R3(config)#frame-relay switching
R3(config)#int s0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay intf-type dte
R3(config-if)#int s0/0.301 point-to-point
R3(config-if)#ip address 10.1.2.3 255.255.255.0
R3(config-if)#frame-relay interface-dlci 301
R3(config-if)#no shut

Task 4:
R1
R1#ping 10.1.1.2
R1#ping 10.1.2.3


Task 5:
R2(config)#ip route 0.0.0.0 0.0.0.0 s0/0.201

R3(config)#ip route 0.0.0.0 0.0.0.0 s0/0.301

Task 6:
R1#show frame-relay map
R1#show frame-relay pvcpvc
R1#ping 10.1.1.2
R1#ping 10.1.2.3

R2#show frame-relay map
R2#show frame-relay pvcpvc2
R2#ping 10.1.1.1
R2#ping 10.1.2.3

R3#show frame-relay map
R3#show frame-relay pvcpvc3
R3#ping 10.1.1.1
R3#ping 10.1.1.2

Frame Relay Static Configuration

Objective: This lab will provide the understanding of how to configure frame relays on Cisco routers. Creating an frame relay links is a fundamental skill that network engineers need to be able to perform.

Purpose: Frame relay is a WAN technology used to send frames over virtual circuits that are locally identified as Data Link Connection Identifier (DLCI) numbers. In this lab we will use a preconfigured frame relay switch which can be found here. The purpose will be to configure three remote office routers to enable frame relay communication from the remote offices to each other office.

Topology:

frame

Task 1: Use the proper cables to connect the ports as shown in the topology.

Task 2:  Configure host names on routers R1, R2, and R3 as shown in the topology.

Task 3:  Configure IP addresses as shown in the topology.

Task 4: Enable frame relay switching and configure the interfaces for frame relay on each router in the topology.

Task 5: Verify configuration is working on all routers by pinging from R1 to R2 and R3.

Task 6:  Enable full mesh between all offices. (this will disable inverse ARP)

Task 7: Configure static frame relay routes to R1 on R2 and R3 to fix inverse ARP being disabled.

Task 8: Verify full configuration is working on all routers and ping from every device to every other device.

ANSWER:

Task 1:
We need to use a crossover cables to connect two like devices.

Task 2:
R1
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#

R2
Router>en
Router#conf t
Router(config)#hostname R2
R2(config)#

R3
Router>en
Router#conf t
Router(config)#hostname R3
R3(config)#

Task 3:
R1
R1#conf t
R1(config)#int s0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shut

R2
R2#conf t
R2(config)#int s0/0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shut

R3
R3#conf t
R3(config)#int s0/0
R3(config-if)#ip address 10.1.1.3 255.255.255.0
R3(config-if)#no shut

Task 4:
R1#conf t
R1(config)#frame-relay switching
R1(config)#int s0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay intf-type dte
R1(config-if)#no shut

R2#conf t
R2(config)#frame-relay switching
R2(config)#int s0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay intf-type dte
R2(config-if)#no shut

R3#conf t
R3(config)#frame-relay switching
R3(config)#int s0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay intf-type dte
R3(config-if)#no shut

Task 5:
R1#show frame-relay pvcFrameR1
R1#show frame-relay map
Here is where we run into problems with running a virtual lab. From the GNS3 docs “GNS3/Dynamips doesn’t emulate the physical layer which is why the serial connections work even though they are both DCE.” and Packet Tracer does not support  frame relay switching from a router perspective. Entering the above command is blank because we are unable to set our office routers side to DTE to obtain clocking and the frame-relay route (Just one of many reason I prefer real equipment). If in a real lab you will get the below.mapR1

R2#show frame-relay pvcframeR2
R2#show frame-relay map

mapR2

R3#show frame-relay pvcframeR3
R3#show frame-relay map

mapR3

Task 6:
R2(config)#int s0/0
R2(config-if)# frame-relay map ip 10.1.1.3 201 broadcast

R3(config)#int s0/0
R3(config-if)# frame-relay map ip 10.1.1.2 301 broadcast

Task 7:
R2(config)#int s0/0
R2(config-if)# frame-relay map ip 10.1.1.1 201 broadcast

R3(config)#int s0/0
R3(config-if)# frame-relay map ip 10.1.1.1 301 broadcast

Task 8:
R1#ping 10.1.1.2
R1#ping 10.1.1.3

R2#show frame-relay map
r2final

R2#ping 10.1.1.1
R2#ping 10.1.1.3

R3#show frame-relay map

r3final
R3#ping 10.1.1.1
R3#ping 10.1.1.2

HOW TO Setup a Frame Relay Switch

This how to guide gives you the full configuration needed to build your own frame relay switch. Setting up a frame relay switch is not an objective for ICND2 so it is not structured as a lab.

Topology:

frame

The GNS3 file with the frame relay switch fully configured can be downloaded here. Image used is c2691-advipservicesk9-mz.124-15.T6 or you can copy and paste the config from below into your own equipment. (Using this as a virtual lab setup will not populate the frame-relay routes fully because neither GNS3 or Packet tracer support full frame-relay switching configurations. It does work perfectly on real equipment.)

___________________________________

hostname FR-SWITCH

frame-relay switching

interface serial0/0

description Connected to R1

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 102 interface serial0/1 201

frame-relay route 103 interface serial0/2 301

clock rate 800000

no shutdown

interface serial0/1

description Connected to R2

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 201 interface serial0/0 102

clock rate 800000

no shutdown

interface serial0/2

description Connected to R3

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 301 interface serial0/0 103

clock rate 115200

no shutdown

end

____________________________________

To configure the frame relay spokes follow the Frame Relay Configuration lab.

 

 

 

EtherChannel

Objective: This lab will provide the understanding of how to configure EtherChannel on Catalyst switches. Creating an Etherchannel is a fundamental skill that network engineers need to be able to perform.

Purpose: Etherchannel, also known as link aggregation is implemented when multiple switch ports are connected between two or more switches and enable us to load balance, create higher throughput, and redundancy between the switches. Normally when two or more links are connected between switches and STP is enabled one of the ports will be placed into blocking mode allowing traffic to only flow over one link. To get past STP blocking on one port you can aggregate two or more links into one virtual link with Etherchannel.

Etherchannel /Link Aggregation standards:

  • To enable Etherchannel on ports each side must match in speed, duplex, mode, and VLAN assignment or links will not form.
    • Port modes
      • PAgP (Port Aggregation Protocol)
      • LACP (Link Aggregation Protocol)
  • Industry standard term is IEEE 802.3ad
  • The Cisco-proprietary hash algorithm for Etherchannel computes values in a range from 0 to 7 so the maximum number of ports you can have in one Etherchannel is 8 ports.

Topology:

etherchannel

Task 1: Use the proper cables to connect the ports as shown in the topology. (Hint: if you are using 2950 or older switches they do not support auto mdix)

Task 2:  Configure host names on both switches as shown in the topology.

Task 3: Set interface modes for ports shown in topology. (must match on both switches)

Task 4: Configure channel group and mode. (must match on both switches)

Task 5: Configure ports as trunks with proper encapsulation.

Task 6: Verify configuration is working and all ports are in an UP and UP state.

Your config should resemble below when done with the lab.

ether

trunk

 

ANSWER:

Task 1:
We need to use a crossover cable to connect two like devices. (If your switch is newer it will support auto mdix and you can use either crossover or straight through, just remember to enable auto mdix)

Task 2:

SW1
Switch>en
Switch#conf t
Switch(config)#hostname SW1
SW1(config)#

SW2
Switch>en
Switch#conf t
Switch(config)#hostname SW2
SW2(config)#

Task 3:
SW1(config)#int range f0/1 – 2
SW1(config-if-range)#speed auto
SW1(config-if-range)#duplex auto

SW2(config)#int range f0/1 – 2
SW2(config-if-range)#speed auto
SW2(config-if-range)#duplex auto
Task 4:
SW1(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1

SW2(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1

Task 5:
SW1(config-if-range)#int port-channel 1
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk

SW2(config-if-range)#int port-channel 1
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk

Task 6:
SW1#show ip interface brief
SW1#show interface trunk

 

 

Summary Addressing

Route summarization, also called route aggregation, is a method of minimizing the number of routing tables in an IP network. It works by consolidating similar IP addresses into one summarized route. The fastest and easiest way is to simply convert the first uncommon octet into binary.

Example 1:

Summarize the group

172.16.40.0

172.16.44.0

172.16.48.0

172.16.52.0

Step 1: Convert the first none common octet of each address into binary.

172.16.40.0 .00101000.00000000

172.16.44.0 .00101100.00000000

172.16.48.0 .00110000.00000000

172.16.52.0 .00110100.00000000

Step 2: Match from left to right the bits that are the same, as soon as one bit is dissimilar from the others draw a line which becomes the mask.

172.16.40.0 .00101000.00000000

172.16.44.0 .00101100.00000000

172.16.48.0 .00110000.00000000

172.16.52.0 .00110100.00000000

Starting at /16 count over to the last matching bit and that is the summary mask, here it is /19.

The summarized route is 172.16.32.0 /19

IPv4 Address Classes

  • An IPv4 address is 32 bits long separated into four groups of 8 bits each (octets).
  • A IP address is represented in a dotted decimal format (192.168.10.10).
  • There are 3 usable unicast IP address classes A, B, and C.
  • The first octet represents the class of address.

classes

boundaries

  • Know that the 127 range is used only for loopback testing.
  • Class D is used for multicast protocols, important ones to know are:
    • 224.0.0.1 Multicast to all hosts on same segment
    • 224.0.0.2 Multicast to all routers on same segment
    • 224.0.0.4 Distance vector routing protocols
    • 224.0.0.5 OSPF Hello packets
    • 224.0.0.6 OSPF Designated Router (DR)
    • 224.0.0.9 RIPv2
    • 224.0.0.10 EIGRP Send routing information
    • 224.0.0.18 VRRP
    • 224.0.0.102 HSRP
    • 224.0.1.1 NTP
  • Clas E is reserved for research.

Convert Decimal to Binary

Converting a whole decimal number to binary is the base skill needed to understand IP subnetting.

You should first know that an IP address contains 4 octets each separated by a decimal point.

octet

Each octet is equal to 1 byte or 8 bits so a full address has 32 bits total (8×4=32).

To convert a number in one octet of an IP address you just need to know that each octet contains 8 binary bits. Binary uses either a 0 or a 1 to represent bits being on or off. All 8 bits on would be eight 1’s (11111111) and all 8 bits off would be eight 0’s (0000000). Each on bit represents a multiple of 2 in decimal format. Knowing each bit is multiple of 2 you can create a binary conversion table.

Starting at 1 for first bit write a 1, then 1×2 = 2, 2×2=4, 2×4=8, 2×8=16, 2×16=32, 2×32=64, 2×64=128

128    64    32    16    8    4    2    1

This is also known as the power of 2 or 2where n equals bits used.

Example 1:

conversion

Practice! Practice! Practice!

Reverse Engineer IP Address

Reverse engineering IP addresses is probably the most important skill to being able to troubleshoot network issues. Using these steps you will be able to find the broadcast address, subnet address, wildcard mask, assignable host addresses, and number of assignable hosts all from a given IP address.

Summary of steps:

Step 1: Find the block size.

Step 2: Divide last network octet by block size

Step 3: Multiple result by block size.

Step 4: Write out subnet and network

Given a host address of 10.50.40.139 /21 find the subnet and broadcast address it belongs to.

Step 1: Find the block size.

block

To find the block size take our known /21 and knowing that /16 is on the boundary subtract 21 from 16 which equals 5. Now count from the left of the over 5 bits, draw a line and square out out block size which here equals 8.

Step 2: Divide last network octet by block size

With /21 being in the 3rd octet we use the .40 from the network address and divide that by our block size of 8 (40 / 8 = 5). If there is a remainder it is simply discarded.

Step 3: Multiple result by block size.

Take the result of 5 and multiply it by our block size of 8 to get 40. (This step can be skipped if no remainder results from step 2.

Step 4: Write out subnet and network.

Written out the subnet = 10.50.40.0

Block size of 8 says the next subnet = 10.50.48.0

Subtract one less from next subnet to get broadcast = 10.50.47.255

Assignable host range = 10.50.40.1 – 10.50.47.254

Mask = 255.255.248.0

reverse of net mask is Wildcard  = 0.0.7.255

To find total usable hosts use the 2n scale. There is 8 hosts bits in 4th octet + 3 in the 3rd octet for hosts = 11 bits which then put into 2n scale shows 2048 hosts minus 2 hosts (one for subnet address and one for broadcast address).

2nscal

Total assignable hosts = 2046

Subnet Key

The key to making subnetting easy is the use of the subnet key and the 2 to the n scale. The subnet key represents a single number known as 8 bits in an IP address byte (1 octet) and can be created when ever needed by hand.

Subnet Key

subnetchart

The second key is the 2 to the n scale. This box represents the number of hosts or subnets created with associated bits used or borrowed.

2 to the n scale

2n

Example 1:

Given an IP address of 192.168.10.50 with subnet mask of 255.255.255.192 draw a line at the 192 mask and box the block size.

blockz

From the subnet key it shows that with a mask of 192 the block sizes will be 64 and will have 6 host bits and 26 network bits. Knowing there is 6 host bits use the 2 to the n scale by counting 6 bits over to see there can be 64 addresses available.

64bits

Subtract 2 from the 64 (one for broadcast, one for subnet) to see there is 62 assignable host addresses forour IP address and subnet mask.

 

 

 

IP Network Design

Given a standard class B address, design a subnetting scheme to support 4 offices, a Central office needing 23 subnets and 200 hosts, Branch A with 8 subnets and 50 hosts, Branch B with 11 subnets and 50 hosts, and Branch C with 12 subnets and 150 hosts. No one office will have any more than 200 hosts needed for future growth.

subs

Step 1:

First we need to add up the total number of subnets needed.

23

12

11

+ 8

57 subnets needed

Step 2:

Knowing we need to borrow bits from the left from our given standard class B address (172.16.0.0 /16) and that we need at least 57 subnets we can use our 2 to the n scale.

2n2

We see that to be able to assign at least 57 subnets we need to go to the next highest available of 64 and that we need to borrow 6 bits from our host side of the address using the subnet chart. At the 6th bit we then draw a line to see that our block size is 4 and our mask is 252 or /22.

subnetchart2

Step 3:

We can now build our subnet addressing scheme starting with the office that needs the largest number of subnets and hosts which is the Central Office needing 23 subnets. Knowing we will be using block sizes of 4 from above we will start at our beginning address of 172.16.0.0 and increment each subnet in groups of 4. We can also see that we have 10 bits still available for hosts which by using the 2n scale shows us we have 1024 hosts or 1022 assignable hosts, far more than our needed 200 hosts per subnet but it does fit our parameters.

subnetssOur Central Office subnets = 172.16.0.0 – 172.16.88.0

Next largest is Branch C which needs 12 subnets and 150 hosts. Starting at the next available subnet of 172.16.92.0 we will continue.

12

Our Branch C subnets = 172.16.92.0 – 172.16.136.0

Next largest is Branch B which needs 11 subnets and 50 hosts. Starting at the next available subnet of 172.16.140.0 we will continue.

11

Our Branch B subnets = 172.16.140.0 – 172.16.180.0

Next largest is Branch A which needs 8 subnets and 50 hosts. Starting at the next available subnet of 172.16.184.0 we will continue.

8

Our Branch A subnets = 172.16.184.0 – 172.16.212.0

We then just need one subnet each per serial link.

Branch C will be 172.16.216.0

Branch B will be 172.16.220.0

Branch A will be 172.16.224.0

final